Failing Results with Future Dates
Incident Report for Ghost Inspector
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 12:04 PST
Monitoring
We've identified 805 test results system-wide that were run with an erroneous future timestamp over the past 12 hours while the troublesome host was in operation. This affected roughly 0.3% of the tests run during that time period. We have purged these erroneous results from the system due to the problems created by the future timestamp.

We apologize if you were affected by this issue. If your test is still in a failing state, we suggest re-running the test to generate a fresh, new result.

We will continue monitoring this issue throughout the day and will be working to put additional checks in place to prevent an incident like this from happening again in the future.
Posted Feb 04, 2020 - 10:48 PST
Identified
We've identified the issue. A specific test running host in our fleet encountered an issue that affected its system clock. This resulted in erroneous dates being assigned to the result and issue being encountered during its execution. We've resolved the host issue. We are now working on cleaning up the erroneous results.
Posted Feb 04, 2020 - 09:23 PST
Investigating
We are investigating reports of failing test results with a future completion date.
Posted Feb 04, 2020 - 09:05 PST
This incident affected: Test Runner.